In order to prevent the reverse engineering of script applications, numerous developers encode their program code with instruments like ionCube PHP Encoder to make it human unreadable. This is valid for paid applications in particular, because anyone would be able to use and modify the unencrypted code without having to pay the necessary license fees. In case you obtain web software encoded with ionCube PHP Encoder, you will be able to use it without a problem as long as a tool called ionCube Loader is available on the website hosting server. This loader makes it possible to run encrypted files and you'll often notice it on the list of prerequisites for a particular script app to be set up. Because the encrypted files are already precompiled, they are ordinarily executed more quickly and this can raise the general speed of your website.
IonCube in Shared Hosting
IonCube Loader is supplied with each Linux shared hosting that we provide and you're able to enable it anytime with only a couple of clicks, so you can use script apps that require it. You're able to do that through the PHP Configuration section of the Hepsia Control Panel and all it will take to activate or deactivate ionCube is to click a single button. The change takes effect in a minute, which means that you'll be able to go ahead and install the application that you would like right away. The very same section allows you to change the PHP release that is active for your account, as we support a variety of versions on our leading-edge cloud hosting platform. If you switch to a version that you have never used so far, you will have to activate ionCube Loader again. More advanced users can use a php.ini file in a particular domain folder in order to set a PHP version different from the one for the entire account or enable/disable ionCube Loader.
IonCube in Semi-dedicated Servers
Because all the semi-dedicated server accounts are set up on our advanced cluster platform and ionCube Loader is available on it, you'll be able to use any script application which requires the tool so as to work properly. With a couple of clicks in the Hepsia website hosting Control Panel you are able to activate or deactivate ionCube for the PHP version that's currently active for your account. Because we support multiple versions of PHP concurrently, you will need to do that every time you move to a different release, and if you revert back to a version that you've already used, our system will remember your choice and ionCube Loader will already be activated. In case you have multiple websites inside the same account and they need different versions of PHP, you will be able to create a php.ini file in each and every domain folder and with a couple of lines of code you are able to define both the PHP version as well as the status of ionCube regardless of what is selected for the website hosting account altogether.