PHP is one of the most commonly used general-purpose server-side scripting languages. It is quite popular because it’s free software, which you can use to develop responsive sites like community web portals, e-shops or school websites instead of static HTML websites. A PHP module must be enabled on the server where a PHP-driven site is hosted so that its PHP code can be ‘decoded’. As there are no license taxes for such a module and the language itself provides unlimited options for the web-based applications that you build, there’re hundreds of millions of PHP-powered websites. Additionally, there are tons of open-source PHP scripts, which you can use for your sites without the need to have any coding experience. Since there are different PHP versions, you have to confirm if the same exact version that you used whilst developing your website is available on the server too.
PHP 4, PHP 5, PHP 7 and PHP 8 Support in Shared Hosting
With our Linux shared hosting, you’ll be able to choose the version of PHP that will be enabled for your shared web hosting account, as multiple versions are enabled on our servers. With as little as one click, you’ll be able to switch between PHP 4, 5, 7 and anytime a new version is unveiled in the future, we will include it in the Hepsia Control Panel without removing the earlier versions. In this way, you’ll be able to host all the sites that you’ve developed through the years. Unlike lots of other providers, we will not force you to update such websites, because a script may be out of date, but this doesn’t automatically mean that it’s vulnerable as you may have modified its code to fix security holes. For your convenience’s sake, you will even be able to pick a different version of PHP for each single site hosted in your shared account.
PHP 4, PHP 5, PHP 7 and PHP 8 Support in Semi-dedicated Servers
It’s our unwavering belief that several years spent setting up a site should not be in vain, which suggests that in case you purchase a semi-dedicated server from our company, you will be able to use any script, no matter if it’s new or old. Unlike lots of web hosting suppliers, we support several different PHP versions on our advanced cloud hosting platform – 4, 5 and 7. You will not only have the ability to activate the needed version through your Hepsia hosting Control Panel, but you will also have the option to set a different version for each individual website. The latter can be accomplished simply by uploading an .htaccess file to the root folder of the given site. You can change the version both for a single website and for the entire account and the new settings will take effect in just several minutes. With our web hosting services, you can be sure that you won’t ever experience any site compatibility impediments.